Операции с тегами

Содержание

Дерево тегов #

Менеджер тегов #

Панель управления тегами #

Теги образуют иерархическую структуру — дерево. Дерево тегов отображается в менеджере тегов.

Это изображение имеет пустой атрибут alt; его имя файла - 8sEf_K0KR80ZzMbtamsq4HQ62v9caN4iXNoTrm3iC0fYScH52w3x5YRpWkowtstHqcoLsI7MZOKxPs6iIw2nGdYRB6ezzRYkBvJCpA7wOC-RVW5oUe3sTyE4xLuIucwwynn6yueE
  • Служебные теги показаны в дереве тегов жирным шрифтом. Они используются для
    • описания стандартных определений, принятых в almaGRID (языки, календари, пользователи, и т.п.),
    • использования в составе скриптов и макетов форматов.
  • Теги, определенные пользователем, показаны в дереве тегов нормальным шрифтом. Если не удается найти перевод тега на текущий язык модели, то берется тег на наиболее близком языке и такой тег в дереве отображается серым цветом. Теги, определенные пользователем, используются для
    • описания элементов модели,
    • задания параметров скриптов,
    • описания переменных макетов форматов,
    • удобства структурирования информации.

Ограничение количества выводимых тегов #

Количество тегов, выводимых на дочернем уровне разворачиваемого тега задается в «almaGRID»-«Настройки»-«Теги»-«Количество загружаемых Тегов при разворачивании узла дерева».

Если количество тегов, выводимых на дочернем уровне, превышает заданный параметр, то в конце списка тегов появляется приглашение «Загрузить еще …».

Синхронизация с базой данных #

Если один пользователь, работающий с сетевой базой данных, изменит название тега в дереве тегов, то автоматически название тега не обновится на панели менеджера грида других пользователей. Для обновления необходимо нажать .

Версия дерева тегов #

При создании базы данных almaGRID автоматически создается дерево тегов, наполненное служебными тегами и предопределенными пользовательскими тегами, полезными при разработке модели.

Версия дерева тегов показана в свойствах базы данных.

Если доступны обновления дерева тегов для текущей базы данных, то становиться активной ссылка «almaGRID»-«Настройки»-«База данных»-«Свойства базы данных»-«Обновить версию дерева Тегов». Обновление версии дерева тегов базы данных может выполнить только Администратор. При обновлении важно:

  • Предварительно сделать резервную копию базы данных.
  • Предварительно обновить программное обеспечение almaGRID у всех пользователей этой базы данных.

Обновления ПО almaGRID (новые версии ПО almaGRID) могут поддерживать более высокие версии дерева тегов. Обычно новые версии дерева тегов содержат новые служебные теги, которые расширяют функциональность скриптового языка.

Теги верхнего уровня #

На самом верхнем «родительском» уровне дерева тегов находятся 4 тега:

«Проекты» — здесь размещаются пользовательские теги для работы с моделями

«Общие теги» — здесь размещаются «рабочие» ветви пользователей базы данных и ветви служебных тегов, в которых определены шаблоны, используемые в моделях.

«Счетчики, перечислители» — здесь размещены теги, которые можно использовать в качестве счетчиков в моделях. Сюда также при автоматическом создании («almaGRID»-«Настройки»-«Теги») записываются теги

  • календарей (год-квартал-месяц-неделя-день) при их автоматическом создании и
  • времени суток

«Служебные теги» — здесь размещены теги, которые используются в составе скриптов и макетов форматов.

Теги в дереве тегов #

Создание и изменение тега #

  1. Клик левой кнопкой мыши на иконку тега, который будет родительским тегом по отношению к создаваемому.
  2. Выбор «Создать Тег».
  3. Ввод названия нового тега на языке, который отображен в верхней-правой части панели менеджера тегов.

Длина названия тега не должна превышать 255 символов.

Новый тег появиться в конце списка тегов, находящихся с ним на одном подуровне.

Чтобы перемещать тег выше или ниже среди тегов, находящихся с ним на одном подуровне, нужно удерживая «Ctrll», нажимать «СтрелкуВверх» или «СтрелкуВниз».

Чтобы поместить тег в начало или в конец списка тегов, находящихся с ним на одном подуровне, нужно удерживая «Ctrll», нажимать «PgUp» или «PgDown».

Чтобы изменить название тега нужно

  • дважды кликнуть на названии тега, отредактировать название и нажать «Enter» или
  • кликнуть левой кнопкой мыши на иконку тега, выбрать «Редактировать Тег», отредактировать название и нажать «Enter».

Код тега #

Каждому тегу присваивается уникальный код. Для отображения кода тега в дереве тегов необходимо выполнить: «almaGRID»-«Теги»-«Инструменты»-«Показать коды Тегов». Код тега будет показан в фигурных скобках перед названием тега.

Чтобы скрыть коды тегов при отображении дерева тегов необходимо выполнить: «almaGRID»-«Теги»-«Инструменты»-«Скрыть коды Тегов»

Редактирование тегов на разных языках #

Нужно кликнуть левой кнопкой мыши на иконку тега, выбрать «Редактировать Тег на всех языках базы данных» и ввести название тега на необходимом языке.

Если среди предлагаемых языков отсутствует язык, который вам нужен, то добавьте его в селектор языков: «almaGRID»-«Настройки»-«Языки»-«Короткий список языков»-кликнуть на нужный язык.

После добавления нового языка он также отобразится в выпадающем списке селектора языков на панели менеджера тегов. Если список языков в селекторе не обновился, то нажмите кнопку в верхней-левой части панели.

При переключении текущего языка теги, для которых определено название на текущем языке, будут показаны черным шрифтом. Если не удается найти перевод тега на текущий язык, то берется название тега на наиболее близком языке и такой тег в дереве отображается серым цветом. 

Копирование тегов в другие ветви #

Копирование тега #

Нужно кликнуть левой кнопкой мыши на иконку тега, выбрать

  • «Копировать только выделенный Тег» — будет скопирован только выделенный Тег.
  • «Копировать Тег и все его подуровни» — будет скопировано все поддерево тегов, берущее начало в выделенном теге.

Копирование нескольких тегов #

Если нужно скопировать несколько тегов, то выделите эти теги

  1. Кликните мышкой на первом теге.
  2. Кликните на следующих тегах при нажатой кнопке «Ctrl».
  3. или, если нужно выделить диапазон элементов — то кликните мышкой на заключительном в диапазоне элементе при нажатой кнопке «Shift».

Кликните левой кнопкой мыши на иконку любого из выделенных тегов и выберите необходимую операцию копирования «Копировать только выделенный Тег» или «Копировать Тег и все его подуровни».

Вставка еще одного экземпляра #

Для вставки тегов в новом месте дерева нужно кликнуть левой кнопкой мыши на иконку тега, который будет родительским тегом по отношению к копируемому и выбрать

«Вставить тот же самый Тег» — исходный тег (или поддерево тегов) будет помещен, как дочерний, по отношению к выбранному родительскому тегу. При этом скопированные теги будут теми же самыми, что и исходные. Это будут еще одни экземпляры исходных тегов, размещенные в других положениях дерева тегов — то есть

  • при изменении названия исходного тега автоматически поменяется название и скопированного и
  • при изменении названия скопированного тега автоматически поменяется название и исходного.

Чтобы найти в дереве тегов все вхождения тега нужно кликнуть левой кнопкой мыши на иконку тега «Иконка тега»-«Найти»-«Найти этот тег во всех ветвях».

Вставка копии тега #

Для вставки копий тегов в новом месте дерева нужно кликнуть левой кнопкой мыши на иконку тега, который будет родительским тегом по отношению к копируемому и выбрать

«Вставить копию Тега» — будут созданы копии тега (или поддерево тегов) путем добавления к названиям исходных тегов текста «(копия хххххххххххххххх)», где хххххххххххххххх — это уникальный идентификатор копии. Изменение названия исходного тега никак не повлияет на изменение названия копий.

Удаление тега из дерева #

Кликните левой кнопкой мыши

  • на иконку тега
  • на иконку одного из выделенных тегов

и выберите «Удалить Тег и все его подуровни».

Если у удаляемого тега есть дочерние теги, то они тоже будут удалены.

Если у удаляемого тега нет других экземпляров в дереве (это последний экземпляр), то появиться предупреждение

В предупреждении красным будут выделены теги, которые привязаны к объектам. Пока тег привязан хотя бы к одному объекту его нельзя удалить.

Для поиска объектов базы данных, к которым привязан тег нужно кликнуть левой кнопкой мыши на иконку тега «Иконка тега»-«Найти»-«Найти Объекты с любым вхождением этого Тега в Теги Объекта».

Будет показан список объектов, к которым привязан данный тег. В данном примере показаны объекты, к которым привязан тег [Прерывание операции 1].

Поиск тега в дереве #

Поиск тега по фрагменту его названия: «almaGRID»-«Теги»-«Поиск»-«Ввести фрагмент названия в поле ‘Искать'»-«Найти и выделить»

Для поиска всех вхождений тега в дерево нужно кликнуть левой кнопкой мыши на иконку тега «Иконка тега»-«Найти»-«Найти этот Тега во всех ветвях».

Теги на рабочем листе #

Размещение тегов в ячейках рабочего листа #

Одиночный тег #

  1. Кликнуть мышкой на ячейке рабочего листа, в которой нужно разместить тег.
  2. «almaGRID»-«Теги»-«Поставить галочку в чек-боксе слева от названия тега»-«Принять»
  3. В ячейке рабочего листа появится тег.

Когда в ячейку рабочего листа помещается тег, то ячейке присваивается имя, которое в специальном формате отображается на панели Excel «Имя ячейки».

Составной тег #

Составной тег — это последовательность тегов по иерархии дерева тегов.

  1. Кликнуть мышкой на ячейке рабочего листа, в которой нужно разместить тег.
  2. «almaGRID»-«Теги»-«Поставить галочки в чек-боксах слева от названий тегов»-«Принять». Можно отмечать галочками только соседние по иерархии дерева теги.
  3. В ячейке рабочего листа появится тег.

Особым составным тегом является тег [=>][ЛюбойТег]. Такой составной тег воспринимается программой как тег, на котором оканчивается дуга графа. Чтобы поместить такой тег в ячейке рабочей книги нужно

  1. Кликнуть мышкой на ячейке рабочего листа, в которой нужно разместить тег вида [=>][ЛюбойТег].
  2. «almaGRID»-«Теги»-«Поставить галочку в чек-боксе слева от названия тега»-«Клювик вниз справа от кнопки Принять»-«Добавить перед Тегом ‘=>’ и принять»
  3. В ячейке рабочего листа появится тег.

Группа тегов #

Группа тегов — это несколько простых или составных тегов, размещенных в одной ячейке рабочего листа.

Для добавления тега в группу: «almaGRID»-«Теги»-«Вкладка ‘Группа тегов'»-«Поставить галочку в чек-боксе слева от названия тега»-«Добавить этот Тег».

Например,
(1) добавляем в группу первый тег — составной тег [Элементы модели] [Целевая функция]

(2) Добавляем в группу второй тег [Состояния элементов модели] и размещаем группу тегов в ячейке рабочей книги.

В ячейке рабочей книги теги группы разделены служебным словом «AND».

Изменение тегов в ячейках рабочего листа #

Редактирование тегов в ячейке #

Если открыта панель «almaGRID»-«Теги», то при клике на ячейке с группой тегов, на этой панели отображается информация о тегах. После выбора тега:

  1. В дереве тегов цветом отмечаются все вхождения этого тега в дерево тегов.
  2. Становятся активными инструменты редактирования.

Инструменты редактирования:

«Сместить Вверх, Вниз» — изменяет порядок следования выделенного тега в группе.

«Подробности о Теге» — показывает информацию о выделенном теге.

«Исключить Тег» — исключает выделенный тег из группы.

«Исключить все Теги» — очищает группу.

На любом этапе редактирования группы тегов к ней можно добавить новый тег, как описано выше.

Если в ячейке размещен один тег (одиночный или составной), то для цветового выделения всех вхождений этого тега в дерево тегов необходимо кликнуть на ссылке с адресом ячейки

Для снятия цветового выделения тегов в дереве: «almaGRID»-«Теги»-«Поиск»-«Снять выделение»

Удаление тегов из ячеек рабочего листа #

Удаление тегов из ячеек рабочей книги выполняется так же, как это принято в Excel —«Выбрать ячейку с тегами»-«Нажать на клавишу ‘Del'»

Копирование ячеек с тегами #

Копирование ячеек с тегами выполняется так же, как это принято в Excel — Перемещение и копирование ячеек. «Выделить ячейки, которые нужно переместить»-«Ctrl-C»-«Выбрать ячейку, куда нужно переместить»-«Ctrl-V».

При копировании с помощью мыши: «Выделить ячейки, которые нужно скопировать»-«Удерживая клавишу ‘Ctrl’, навести указатель мыши на границу выделения»-«Когда указатель примет вид указателя копирования перетащить ячейку в нужное место».

Перемещение ячеек с тегами #

Перемещение ячеек с тегами выполняется так же, как это принято в Excel — Перемещение и копирование ячеек. «Выделить ячейки, которые нужно переместить»-«Ctrl-X»-«Выбрать ячейку, куда нужно переместить»-«Ctrl-V».

При перемещении с помощью мыши: «Выделить ячейки, которые нужно переместить»-«Навести указатель мыши на границу выделения»-«Когда указатель примет вид указателя перемещения  перетащить ячейку в нужное место«.

Дополнительные операции с тегами в ячейках рабочего листа #

Группировка тегов #

Для объединения тегов в группу:«Выделить ячейки с группируемыми тегами»-«Теги»-«Инструменты»-«Объединить Теги в группу»-«Выбрать ячейку для результата».

Для выбора ячейки, куда будет помещён результат группировки тегов, выделите ячейку (кликните по ней мышкой) и нажмите «Ок».

Для разделения группы тегов, помещенной в ячейку: «Выделить ячейку с группой тегов»-«Теги»-«Инструменты»-«Разделить группу тегов»-«Выбрать ячейку для результата».

После выбора ячейки, куда будет помещён результат разгруппировки тегов,

  • будет показан список тегов — результат разгруппировки и
  • предложено настроить параметры размещения полученного списка тегов на рабочем листе.

Создание ряда тегов в последовательных ячейках #

Для создания списка тегов из иерархии дерева и его размещения в ячейках рабочей книги: «Теги»-«Выделить исходный тег в дереве тегов (кликнуть по названию тега)»-«Инструменты»-«Создать ряд Тегов для Заголовков Грида».

После выбора ячейки, куда будет помещен результат,

появится панель для настройки параметров отбора тегов из дерева относительно исходного тега:

  • номер уровня, начиная с которого будет просматриваться дерево тегов (может быть как выше, так и ниже уровня исходного тега),
  • номер уровня, заканчивая на котором будет просматриваться дерево тегов (может быть как выше, так и ниже уровня исходного тега),
  • правила отбора тегов из ветвей, попавших в просматриваемый диапазон уровней дерева тегов, и правила формирования составных тегов.

Преобразование ячеек с текстом в теги #

«Выделить диапазон ячеек»-«Теги»-«Инструменты»-«Заменить текст в ячейках Тегами»

В ячейки с текстом, соответствующим названиям тегов базы данных будут помещены теги. Ячейки с текстом, не совпадающим с названиями тегов базы данных останутся без изменения.

Можно изменять параметры поиска названий тегов в базе данных

  • с префиксом — в базе данных будут найдены названия вида, в которых тексту к тексту их ячеек предшествует префикс,
  • с суффиксом — в базе данных будут найдены названия вида, в которых к тексту их ячеек добавлен суффикс,
  • точно — поиск по полному или частичному совпадению текста их ячеек.

Из найденных в базе данным тегов можно создавать составные теги добавляя перед ними выбранные теги. Например, если выбрать тег предыдущего уровня [=>]

то будет получен следующий результат

Чтобы преобразовать теги в ячейках в текст, соответствующий их названиями: «Выделить диапазон ячеек»-«Теги»-«Инструменты»-«Заменить Теги в ячейках на текст»

Экспорт и импорт тегов #

Экспорт тегов в файл #

Можно экспортировать в файл все поддерево тегов, берущее начало в экспортированном теге

  • без указания расположения и
  • с указанием расположения экспортируемого тега в дереве относительно тегов верхнего уровня.

Можно экспортировать тег и его дочерние теги без указания расположения в дереве тегов: «Теги»-«Выделить исходный тег в дереве тегов (кликнуть по названию тега)»-«Инструменты»-«Экспорт/Импорт Тегов»-«Экспортировать Тег». При этом создается файл с расширением «.atrm», импорт которого возможен в любое выбранное пользователем расположение в дереве тегов.

Можно экспортировать тег и его дочерние теги с указанием расположения в дереве тегов: «Теги»-«Выделить исходный тег в дереве тегов (кликнуть по названию тега)»-«Инструменты»-«Экспорт/Импорт Тегов»-«Экспортировать Тег с путем от корневого узла».

Например, если экспортируемый тег является потомком тега «Проекты», то в а создаваемом файле с расширением «.adat» будет сохранена информация о пути от тега верхнего уровня «Проекты» до экспортируемого тега. При импорте такого файла в другую базу данных

  • в дереве тегов будет автоматически создана ветвь от тега «Проекты» до экспортированного тега и
  • создано все поддерево, берущее начало в экспортированном теге.

Импорт тегов из файла #

Импорт файла «.atrm»: «Теги»-«Выделить тег, который будет родительским по отношению к импортируемым (кликнуть по названию тега)»-«Инструменты»-«Экспорт/Импорт Тегов»-«Импортировать Тег».

Импорт файла «.adat»: «Теги»-«Инструменты»-«Экспорт/Импорт Тегов»-«Импортировать Тег c с путем от корневого узла».

ВНИМАНИЕ: Перед импортом тегов сделайте резервную копию базы данных.

После выбора импортируемого файла необходимо выбрать язык, на котором будет выполнен контроль дубликатов названий тегов.

При импорте тегов из файла выполняется проверка на

  • дублирование названий тегов (в дереве тегов уже присутствуют теги с названиями из из импортируемого файла),
  • дублирование кодов тегов (в дереве тегов уже присутствуют теги с кодами из из импортируемого файла).

По результатам проверки на дубликаты необходимо принять действие по их импорту:

  • заменить тег в базе данных импортируемым или
  • оставить тег уже присутствующий в базе данных и игнорировать тег из импортируемого файла.

Экспорт тегов на рабочий лист #

Для экспорта тега на рабочий лист: «Теги»-«Выделить тег в дереве тегов (кликнуть по названию тега)»-«Инструменты»-«Поместить названия Тегов на рабочем листе».

После выбора способа размещения названий тегов на рабочем листе и выбора стартовой ячейки на рабочем листе информация из дерева тегов будет помещена на рабочий лист.

При выборе «Разместить теги в виде дерева»:

При выборе «Разместить теги в виде таблицы»:

Параметры экспорта тегов

  • «Только раскрытые теги» — будут экспортированы только те дочерние теги, которые раскрыты в дереве тегов.
  • «Добавлять коды и язык тегов» — к тегам будут добавлены их коды и язык названий.

Импорт тегов с рабочего листа #

Для импорта тегов из ячеек рабочего листа: «Выделить диапазон ячеек с названиями тегов»-«Выделить тег, который будет родительским по отношению к импортируемым (кликнуть по названию тега)»-«Теги»-«Инструменты»-«Принять названия Тегов из ячеек рабочей книги«.

Указанным выше способом можно импортировать диапазоны, в которых находится иерархия тегов размещенная как в виде таблицы, так и в виде дерева.

Для импорта тегов из ячеек рабочего листа с кодами и языком: «Выделить диапазон ячеек с кодами, языком и названиями тегов»-«Выделить тег, который будет родительским по отношению к импортируемым (кликнуть по названию тега)»-«Теги»-«Инструменты»-«Принять коды, язык и названия Тегов из ячеек рабочей книги«.

ВНИМАНИЕ: Перед импортом тегов сделайте резервную копию базы данных.

После выбора импортируемого диапазона выполняется процедура проверки дубликатов.

Импорт тегов с кодами и языком можно использовать для перевода целых поддеревьев на другие языки. Для этого

  • в столбце с названием языка нужно указать название нового языка языка (поддерживаемые языки приведены в ветви дерева тегов [Служебные Теги]-[Языки]-[Все языки]),
  • в ячейках с названием тегов указать названия тегов на новом языке,
  • импортировать отредактированный диапазон с кодами и языком тегов.

Если вы нашли ошибку, пожалуйста, выделите фрагмент текста и нажмите Ctrl+Enter.

ru_RURussian

Сообщить об опечатке

Текст, который будет отправлен нашим редакторам: